Metadata Extraction failure with read timeout to airflow cluster - Elevated Error
Incident Report for Alation Cloud Service
Resolved
The incident had been resolved and we have not seen the error reoccur during our monitoring period.
Posted Oct 31, 2024 - 18:38 UTC
Monitoring
Our engineering team has successfully resolved the issue causing the timeout connection to the Airflow pipeline service, and the system is now functioning as expected.
Posted Oct 30, 2024 - 22:45 UTC
Update
The issue is impacting US-east region only. All other regions are fully operational.
Following error message may be seen in impacted region.
"HTTPConnectionPool(host='airflow-pipeline-service.default.svc.cluster.local', port=80): Read timed out. (read timeout=1800) "
Posted Oct 30, 2024 - 20:17 UTC
Investigating
We are currently investigating an issue with the MDE Pipeline service, which is preventing data extraction and causing errors. The error is related to a timeout connection to the pipeline service. Our team is working to resolve the issue as quickly as possible.

We will keep you posted with the progress as it becomes available.
Posted Oct 29, 2024 - 23:30 UTC
This incident affected: Alation Cloud Service (Americas (US-east), Americas (US-west), Canada (Montreal), EMEA (Ireland), EMEA (Frankfurt), APAC (Sydney), APAC (Singapore), APAC (Tokyo)).