Third-party provider outage (AWS)

Incident Report for Alation Cloud Service

Resolved

The underlying AWS service has recovered, and all Alation services have returned to normal operation for affected customers. Our teams will continue to monitor the environment to ensure continued stability.
Posted Oct 20, 2025 - 10:00 UTC

Monitoring

AWS further reports “significant signs of recovery”: most requests should now be succeeding, though some services still have latency and backlog to clear. We see early signs of Alation service recovery; we will keep you updated.
Posted Oct 20, 2025 - 09:54 UTC

Update

AWS states that they are still working on finding the root cause and actively working on the issue.
Posted Oct 20, 2025 - 08:45 UTC

Identified

We have detected elevated error rates and degraded performance across parts of the Alation platform. This is caused by a service disruption at AWS, which is affecting one or more of their core services that Alation depends on. Our own systems are healthy, but upstream instability is affecting service delivery for our users.

Impact:
Some users may experience slower response times, timeouts, or failures when using certain features (for example: data catalog search, ingestion jobs, API calls or dashboard refreshes).

Data integrity is not impacted; no data loss or corruption has been detected. Queued operations will retry automatically once upstream services recover.
Posted Oct 20, 2025 - 07:40 UTC
This incident affected: Alation Cloud Service - Dev (Americas (US-east) - Dev) and Alation Cloud Service (Americas (US-east)).